nixos-config/configuration.nix

370 lines
11 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
#your system. Help is available in the configuration.nix(5) man page, on
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
{ config, lib, pkgs, ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
<home-manager/nixos>
];
# Use the systemd-boot EFI boot loader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
# amdgpu stuffs
boot.initrd.kernelModules = [ "amdgpu" ];
services.xserver.videoDrivers = [ "amdgpu" ];
# opengl support
hardware.opengl.enable = true;
# opengl packages
hardware.opengl.extraPackages = with pkgs; [
rocm-opencl-icd
rocm-opencl-runtime
vaapiVdpau
libvdpau-va-gl
];
hardware.opengl.driSupport = true;
networking.hostName = "sky-laptop"; # Define your hostname.
# Pick only one of the below networking options.
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
# Set your time zone.
time.timeZone = "America/Los_Angeles";
# Configure network proxy if necessary
# networking.proxy.default = "http://user:password@proxy:port/";
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
console = {
font = "Lat2-Terminus16";
#keyMap = "us";
useXkbConfig = true; # use xkb.options in tty.
};
# Enable the X11 windowing system
services.xserver.enable = true;
services.xserver.displayManager.sessionCommands = ''
slstatus &
nitrogen --restore &
clipcatd &
'';
# Configure keymap in X11
services.xserver.xkb.layout = "us";
# services.xserver.xkb.options = "eurosign:e,caps:escape";
# Enable CUPS to print documents.
# services.printing.enable = true;
# Enable sound.
sound.enable = true;
hardware.pulseaudio.enable = true;
# Enable touchpad support (enabled default in most desktopManager).
services.xserver.libinput.enable = true;
# Enable dwm
services.xserver.windowManager.dwm.package = pkgs.dwm.overrideAttrs {
src = ./dwm;
};
services.xserver.windowManager.dwm.enable = true;
# Sky User
users.users.sky.isNormalUser = true;
users.users.sky.extraGroups = [ "wheel" ]; # Enable sudo for the user.
nixpkgs.config.allowUnfreePredicate = pkg:
builtins.elem (lib.getName pkg) [
"obsidian"
];
nixpkgs.config.permittedInsecurePackages =
lib.optional (pkgs.obsidian.version == "1.4.16") "electron-25.9.0";
home-manager.useGlobalPkgs = true;
# Home Manager for Sky
home-manager.users.sky = {pkgs, ...}: {
home.packages = with pkgs; [
obsidian
(callPackage (./rolldice/default.nix) {})
clang-tools
rclone
trash-cli
mumble
nheko
zim
moonlight-embedded
nitrogen
firefox-bin
neofetch
ncpamixer
tree
xclip
grpc
clipcat
keepassxc
jellyfin-media-player
];
services.picom = {
enable = true;
vSync = true;
backend = "glx";
inactiveOpacity = 0.9;
settings = {
blur = {
method = "dual-kawase";
};
};
};
programs.bash = {
enable = true;
shellAliases = {
nv = "nvim";
ccm = "clipcat-menu";
};
};
programs.git = {
enable = true;
userName = "Sky Hearn";
userEmail = "sky.hearn@pm.me";
signing = {
key = "DAB485883AE426EC";
signByDefault = false;
};
};
programs.neovim = {
enable = true;
defaultEditor = true;
extraConfig = ''
set shiftwidth=2 smarttab
set expandtab
set tabstop=8 softtabstop=0
'';
extraPackages = with pkgs; [
# Use the project flake's language server to prevent version mismatches
# clang_12
# rust-analyzer
];
plugins = with pkgs.vimPlugins; [
{
plugin = gruvbox-nvim;
type = "viml";
# Better performance is off until I can figure out a way to make the cache outside the nix store
config = ''
if has('termguicolors')
set termguicolors
endif
colorscheme gruvbox
'';
}
{
plugin = lualine-nvim;
type = "lua";
config = ''
require'lualine'.setup {
options = {
theme = 'gruvbox'
},
sections = {
lualine_c = {'lsp_progress'}
}
}
'';
}
{
plugin = lsp-status-nvim;
type = "lua";
config = ''
require'lsp-status'.register_progress()
'';
}
{
plugin = nvim-lspconfig;
type = "lua";
config = ''
-- Mappings.
-- See `:help vim.diagnostic.*` for documentation on any of the below functions
local opts = { noremap=true, silent=true }
vim.keymap.set('n', '<space>e', vim.diagnostic.open_float, opts)
vim.keymap.set('n', '[d', vim.diagnostic.goto_prev, opts)
vim.keymap.set('n', ']d', vim.diagnostic.goto_next, opts)
vim.keymap.set('n', '<space>q', vim.diagnostic.setloclist, opts)
-- Use an on_attach function to only map the following keys
-- after the language server attaches to the current buffer
local on_attach = function(client, bufnr)
-- Set up status tracking
require'lsp-status'.on_attach(client)
-- Enable completion triggered by <c-x><c-o>
vim.api.nvim_buf_set_option(bufnr, 'omnifunc', 'v:lua.vim.lsp.omnifunc')
-- Mappings.
-- See `:help vim.lsp.*` for documentation on any of the below functions
local bufopts = { noremap=true, silent=true, buffer=bufnr }
vim.keymap.set('n', 'gD', vim.lsp.buf.declaration, bufopts)
vim.keymap.set('n', 'gd', vim.lsp.buf.definition, bufopts)
vim.keymap.set('n', 'K', vim.lsp.buf.hover, bufopts)
vim.keymap.set('n', 'gi', vim.lsp.buf.implementation, bufopts)
vim.keymap.set('n', '<C-k>', vim.lsp.buf.signature_help, bufopts)
vim.keymap.set('n', '<space>wa', vim.lsp.buf.add_workspace_folder, bufopts)
vim.keymap.set('n', '<space>wr', vim.lsp.buf.remove_workspace_folder, bufopts)
vim.keymap.set('n', '<space>wl', function()
print(vim.inspect(vim.lsp.buf.list_workspace_folders()))
end, bufopts)
vim.keymap.set('n', '<space>D', vim.lsp.buf.type_definition, bufopts)
vim.keymap.set('n', '<space>rn', vim.lsp.buf.rename, bufopts)
vim.keymap.set('n', '<space>ca', vim.lsp.buf.code_action, bufopts)
vim.keymap.set('n', 'gr', vim.lsp.buf.references, bufopts)
vim.keymap.set('n', '<space>f', function() vim.lsp.buf.format { async = true } end, bufopts)
end
local lsp_flags = {
-- This is the default in Nvim 0.7+
debounce_text_changes = 150,
}
local servers = { 'clangd', 'rust_analyzer' }
for _, lsp in ipairs(servers) do
require'lspconfig'[lsp].setup(
vim.tbl_extend('keep',
require('coq').lsp_ensure_capabilities({
on_attach = on_attach,
flags = lsp_flags
}) or {},
require'lsp-status'.capabilities
)
)
end
'';
}
{
plugin = coq_nvim;
type = "lua";
config = ''
vim.g.coq_settings = { auto_start = 'shut-up', xdg = true }
'';
}
{
plugin = nvim-treesitter.withAllGrammars;
type = "lua";
config = ''
require'nvim-treesitter.configs'.setup {
-- TODO: Make this use stdpath("data")
-- parser_install_dir = "~/.local/share/nvim/site",
-- ensure_installed = { "nix", "help", "rust", "c", "lua" },
-- auto_install = true,
highlight = {
enable = true
},
incremental_selection = {
enable = true,
keymaps = {
init_selection = "gnn", -- set to `false` to disable one of the mappings
node_incremental = "grn",
scope_incremental = "grc",
node_decremental = "grm",
}
},
indent = {
enable = true
},
}
vim.cmd([[
set foldmethod=expr
set foldexpr=nvim_treesitter#foldexpr()
set nofoldenable
]])
'';
}
{
plugin = telescope-nvim;
}
];
};
home.stateVersion = "23.11";
};
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
wireguard-tools
pinentry
pulseaudio
bash
vim
wget
acpi
dmenu
dunst
libnotify
(pkgs.st.overrideAttrs (_: {
src = ./st;
})
)
(pkgs.slstatus.overrideAttrs (_: {
src = ./slstatus;
})
)
libva-utils
];
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
programs.mtr.enable = true;
# List services that you want to enable:
# Enable the OpenSSH daemon.
services.openssh.enable = true;
# https://discourse.nixos.org/t/cant-get-gnupg-to-work-no-pinentry/15373/19
services.pcscd.enable = true;
programs.gnupg.agent = {
enable = true;
pinentryFlavor = "tty";
};
# Open ports in the firewall.
# networking.firewall.allowedTCPPorts = [ ... ];
# networking.firewall.allowedUDPPorts = [ ... ];
# Or disable the firewall altogether.
# networking.firewall.enable = false;
# Copy the NixOS configuration file and link it from the resulting system
# (/run/current-system/configuration.nix). This is useful in case you
# accidentally delete configuration.nix.
# system.copySystemConfiguration = true;
# This option defines the first version of NixOS you have installed on this particular machine,
# and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
#
# Most users should NEVER change this value after the initial install, for any reason,
# even if you've upgraded your system to a new NixOS release.
#
# This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
# so changing it will NOT upgrade your system.
#
# This value being lower than the current NixOS release does NOT mean your system is
# out of date, out of support, or vulnerable.
#
# Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
# and migrated your data accordingly.
#
# For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
system.stateVersion = "23.11"; # Did you read the comment?
}